Print the Inverted Half Pyramid Alphabet Pattern

  

A A A A A 
B B B B
C C C
D D
E


Problem Statement:- Program to Print the Inverted Half Pyramid Alphabet Pattern.

Sample Input/Output:-


Sample Input First:E

Sample Output First: 

A A A A A 
B B B B
C C C
D D
E

Sample Input Second: D


Sample Output Second: 

A A A A B B B C C D

   

Data requirement:-


   Input Data:- row_size

  Output Data:- out

  Additional Data:-in or inn(for python)


Program in C

Here is the source code of the C  Program to Print the Inverted Half Pyramid Alphabet Pattern.


Code:

#include <stdio.h>
int main()
{
  printf("Enter the row size(In Alphabet):");
  int outin;
  char row_size;
  scanf("%c", &row_size);
  for (out = 'A'out <= row_sizeout++)
  {
    for (in = row_sizein >= outin--)
      printf("%c "out);
    printf("\n");
  }
}

Input/Output:
Enter the row size(In Alphabet):E
A A A A A 
B B B B 
C C C 
D D 

Program in C++

Here is the source code of the C++  Program to Print the Inverted Half Pyramid Alphabet Pattern.


Code:

#include <iostream>
using namespace std;
int main()
{
    cout << "Enter the row size(In Alphabet):";
    int outin;
    char row_size;
    cin >> row_size;
    for (out = 'A'out <= row_sizeout++)
    {
        for (in = row_sizein >= outin--)
            cout << char(out<< " ";
        cout << "\n";
    }
}


Input/Output:
Enter the row size(In Alphabet):D
A A A A 
B B B   
C C     
D       


Program in Java

Here is the source code of the Java  Program to Print the Inverted Half Pyramid Alphabet Pattern.


Code:

import java.util.Scanner;

public class InvertedHalfPyramidAlphabetPattern {

    public static void main(String[] args) {
        Scanner cs = new Scanner(System.in);
        System.out.println("Enter the row size(In Alphabet):");
        char outin;
        char row_size = cs.next().charAt(0);
        for (out = 'A'out <= row_sizeout++) {
            for (in = row_sizein >= outin--)
                System.out.print(out + " ");
            System.out.println();
        }
        cs.close();
    }
}

Input/Output:
Enter the row size(In Alphabet):F
A A A A A A 
B B B B B
C C C C
D D D
E E
F

Program in Python

Here is the source code of the Python Program to Print the Inverted Half Pyramid Alphabet Pattern.


Code:

row_size = input("Enter the row size(In Alphabet):")
for out in range(ord('A'), ord(row_size)+1):
    for i in range(ord(row_size), out-1, -1):
        print(chr(out), end=" ")
    print("\r")


Input/Output:
Enter the row size(In Alphabet):E
A A A A A 
B B B B
C C C
D D
E



Post a Comment

0 Comments