Print the Half Pyramid Alphabet Pattern

   
A
B B C C C D D D D E E E E E

Problem Statement:- Program to Print the Half Pyramid Alphabet Pattern.

Sample Input/Output:-


Sample Input First:E

Sample Output First: 

A
B B C C C D D D D E E E E E

Sample Input Second: D


Sample Output Second: 

B B
C C C
D D D D

Data requirement:-


   Input Data:- row_size

  Output Data:- out

  Additional Data:-in or inn(for python)


Program in C

Here is the source code of the C Program to Print the Half Pyramid Alphabet Pattern.


Code:

#include <stdio.h>
int main()
{
  printf("Enter the row size(In Alphabet):");
  int outin;
  char row_size;
  scanf("%c", &row_size);
  for (out = 'A'out <= row_sizeout++)
  {
    for (in = 'A'in <= outin++)
      printf("%c "out);
    printf("\n");
  }
}

Input/Output:
Enter the row size(In Alphabet):E
B B
C C C
D D D D
E E E E E

Program in C++

Here is the source code of the C++ Program to Print the Half Pyramid Alphabet Pattern.


Code:

#include <iostream>
using namespace std;
int main()
{
    cout << "Enter the row size(In Alphabet):";
    int outin;
    char row_size;
    cin >> row_size;
    for (out = 'A'out <= row_sizeout++)
    {
        for (in = 'A'in <= outin++)
            cout << char(out<< " ";
        cout << "\n";
    }
}


Input/Output:
Enter the row size(In Alphabet):D
B B
C C C
D D D D

Program in Java

Here is the source code of the Java Program to Print the Half Pyramid Alphabet Pattern.


Code:

import java.util.Scanner;

public class HalfPyramidAlphabetPattern {
    public static void main(String[] args) {
        Scanner cs = new Scanner(System.in);
        System.out.println("Enter the row size(In Alphabet):");
        char outin;
        char row_size = cs.next().charAt(0);
        for (out = 'A'out <= row_sizeout++) {
            for (in = 'A'in <= outin++)
                System.out.print(out + " ");
            System.out.println();
        }
        cs.close();
    }
}


Input/Output:
Enter the row size(In Alphabet):F
B B
C C C
D D D D
E E E E E
F F F F F F

Program in Python

Here is the source code of the Python Program to Print the Half Pyramid Alphabet Pattern.


Code:

row_size = input("Enter the row size(In Alphabet):")
for out in range(ord('A'), ord(row_size)+1):
    for i in range(ord('A'), out+1):
        print(chr(out), end=" ")
    print("\r")


Input/Output:
Enter the row size(In Alphabet):D
B B
C C C
D D D D


Post a Comment

0 Comments