Print the Inverted V Number Pattern

    
    1     
   2 2
  3   3
 4     4
5       5

Problem Statement:- Program to Print the Inverted V Number Pattern.

Sample Input/Output:-


Sample Input First:5

Sample Output First: 

    1     
   2 2    
  3   3   
 4     4  
5       5 

Sample Input Second: 4


Sample Output Second: 

    1    
  2 2
 3   3
4     4

Data requirement:-


   Input Data:- row_size

  Output Data:- out

  Additional Data:-in or inn(for python), print_control_x, print_control_y


Program in C

Here is the source code of the C  Program to Print the Inverted V-shaped Number Pattern.


Code:

#include <stdio.h>
int main()
{
  int outin;
  printf("Enter the row size:");
  int row_size;
  scanf("%d", &row_size);
  int print_control_x = row_size;
  int print_control_y = row_size;
  for (out = 1out <= row_sizeout++)
  {
    for (in = 1in <= row_size * 2in++)
    {
      if (in == print_control_x || in == print_control_y)
      {
        printf("%d"out);
      }
      else
      {
        printf(" ");
      }
    }
    print_control_x--;
    print_control_y++;
    printf("\n");
  }
}

Input/Output:
Enter the row size:5
    1     
   2 2    
  3   3   
 4     4  
5       5

Program in C++

Here is the source code of the C++  Program to Print the Inverted V shape Number Pattern.


Code:

#include <iostream>
using namespace std;
int main()
{
    int outinp;
    cout << "Enter the row size:";
    int row_size;
    cin >> row_size;

    int print_control_x = row_size;
    int print_control_y = row_size;
    for (out = 1out <= row_sizeout++)
    {
        for (in = 1in <= row_size * 2in++)
        {
            if (in == print_control_x || in == print_control_y)
            {
                cout << out;
            }
            else
            {
                cout << " ";
            }
        }
        print_control_x--;
        print_control_y++;
        cout << "\n";
    }
}


Input/Output:
Enter the row size:4
   1
  2 2
 3   3
4     4

Program in Java

Here is the source code of the Java  Program to Print the Inverted V Shape Number Pattern.


Code:

import java.util.Scanner;

public class InvertedVNumberPattern {

    public static void main(String[] args) {
        Scanner cs = new Scanner(System.in);
        System.out.println("Enter the row size:");
        int outin;
        int row_size = cs.nextInt();
        int print_control_x = row_size;
        int print_control_y = row_size;
        for (out = 1out <= row_sizeout++) {
            for (in = 1in <= row_size * 2in++) {
                if (in == print_control_x || in == print_control_y) {
                    System.out.print(out);
                } else {
                    System.out.printf(" ");
                }
            }
            print_control_x--;
            print_control_y++;
            System.out.println();
        }
        cs.close();
    }
}


Input/Output:
Enter the row size:
5
    1     
   2 2    
  3   3   
 4     4  
5       5

Program in Python

Here is the source code of the Python Program to Print the Inverted V Number Pattern.


Code:

row_size = int(input("Enter the row size:"))
print_control_x = row_size
print_control_y = row_size
for out in range(1row_size+1):
    for inn in range(1row_size*2):
        if inn == print_control_x or inn == print_control_y:
            print(outend="")
        else:
            print(" "end="")
    print_control_x -= 1
    print_control_y += 1
    print("\r")


Input/Output:
Enter the row size:6
     1     
    2 2    
   3   3   
  4     4  
 5       5 
6         6


Post a Comment

1 Comments

  1. i could not understand the provided sloution of python ,,,,any video for help?/

    ReplyDelete

Please do not Enter any spam link in the comment box