Program to print inverted right triangle star pattern

*****
****
***
**
*

Problem Statement:- Program to print an inverted right triangle star pattern.

Sample Input/Output:-


Sample Input First:5

Sample Output First: 

*****
****
***
**
*

Sample Input Second: 4


Sample Output Second: 

****
***
**
*


Data requirement:-


  Input Data:- row_size


  Output Data:- *


  Additional Data:- in,out,p


Program in C

Here is the source code of the C Program to print an inverted right triangle star pattern.


Code:


#include<stdio.h>
int main()
{
  printf("Enter the row size:");
  int row_size,out,in;
  scanf("%d",&row_size);
  for(out=1;out<=row_size;out++)
  {
   for(in=row_size;in>=out;in--)
    printf("*");
   printf("\n");
  }
}

Input/Output:
Enter the row size:5
*****
****
***
**
*

Program in C++

Here is the source code of the C++ Program to print an inverted right triangle star pattern.


Code:


#include<iostream>
using namespace std;
int main()
{
  cout<<"Enter the row size:";
  int row_size,out,in;
  cin>>row_size;
  for(out=1;out<=row_size;out++)
  {
   for(in=row_size;in>=out;in--)
    cout<<"*";
     cout<<"\n";
  }
}


Input/Output:
Enter the row size:7
*******
******
*****
****
***
**

*

Program in Java

Here is the source code of the Java Program to print an inverted right triangle star pattern.


Code:


import java.util.Scanner;
public class p2 {

public static void main(String[] args) {

Scanner cs=new Scanner(System.in);
System.out.println("Enter the row size:");
  int row_size,out,in;
  row_size=cs.nextInt();
  for(out=1;out<=row_size;out++)
  {
   for(in=row_size;in>=out;in--)
    System.out.print("*");
   System.out.println();
  }
cs.close();
}
}

Input/Output:
Enter the row size:
4
****
***
**
*


Program in Python

Here is the source code of the Python Program to print an inverted right triangle star pattern.


Code:


print("Enter the row size:")
row_size=int(input())
for out in range(row_size+1):
    for j in range(row_size,out,-1):
        print("*",end="")
    print("\r")

Input/Output:
Enter the row size:
6
******
*****
****
***
**
*




Post a Comment

0 Comments