Print the Full Inverted Pyramid Number Pattern

5 5 5 5 5 
 4 4 4 4 
  3 3 3 
   2 2 
    1 

Problem Statement:- Program to print the Full Inverted Pyramid Number Pattern.

Sample Input/Output:-


Sample Input First:5

Sample Output First: 

5 5 5 5 5
 4 4 4 4
  3 3 3
   2 2
    1

Sample Input Second: 6


Sample Output Second: 

6 6 6 6 6 6 
 5 5 5 5 5 
  4 4 4 4 
   3 3 3 
    2 2 
     1 

Data requirement:-


   Input Data:- row_size

  Output Data:- out

  Additional Data:-in or inn(for python), p

Program in C

Here is the source code of the C Program to print the Full Inverted Pyramid Number Pattern.

Code:

#include<stdio.h>
int main()
{
    int out,in,p;
    printf("Enter the row size:");
    int row_size;
    scanf("%d",&row_size);
    for(out=row_size;out>=1;out--)
    {
     for(in=row_size-1;in>=out;in--)
     {
    printf(" ");
     }
    for(p=out;p>=1;p--)
    {
    printf("%d ",out);
    }
    printf("\n");
}}

Input/Output:
Enter the row size:5
5 5 5 5 5
 4 4 4 4
  3 3 3
   2 2
    1

Program in C++

Here is the source code of the C++ Program to print the Full Inverted Pyramid Number Pattern.

Code:

#include<iostream>
using namespace std;
int main()
{
    int out,in,p;
    cout<<"Enter the row size:";
    int row_size;
    cin>>row_size;
    for(out=row_size;out>=1;out--)
    {
     for(in=row_size-1;in>=out;in--)
     {
    cout<<" ";
     }
    for(p=out;p>=1;p--)
    {
    cout<<out<<" ";
    }
    cout<<"\n";
}}

Input/Output:
Enter the row size:4
4 4 4 4
 3 3 3
  2 2
   1

Program in Java

Here is the source code of the Java Program to print the Full Inverted Pyramid Number Pattern.

Code:

import java.util.Scanner;
public class NumberPattern13 {

public static void main(String[] args) {
Scanner cs=new Scanner(System.in);
        int out,in,p;
    System.out.println("Enter the row size:");
    int row_size=cs.nextInt();
    for(out=row_size;out>=1;out--)
    {
     for(in=row_size-1;in>=out;in--)
     {
    System.out.printf(" ");
     }
    for(p=out;p>=1;p--)
    {
    System.out.print(out+" ");
    }
    System.out.println();
    }
    cs.close();
}
}

Input/Output:
Enter the row size:
5
5 5 5 5 5 
 4 4 4 4 
  3 3 3 
   2 2 
    1 


Program in Python

Here is the source code of the Python Program to print the Full Inverted Pyramid Number Pattern.

Code:

row_size=int(input("Enter the row size:"))
for out in range(row_size,0,-1):
    for inn in range(row_size,out,-1):
        print(" ",end="")
    for p in range(out,0,-1):
        print(out,end=" ")
    print("\r")

Input/Output:
Enter the row size:6
6 6 6 6 6 6 
 5 5 5 5 5 
  4 4 4 4 
   3 3 3 
    2 2 
     1 

Post a Comment

0 Comments